Форум Майнкрафт 🔥 от сайта Black-Minecraft.Com

Приветствуем Вас на нашем новом форуме по Майнкрафт.
Так как вы у нас новенький, пожалуйста — нажмите на кнопку регистрация. Регистрация позволит вам скачивать файлы с форума, спрашивать совета по созданию сервера, оставлять заявки и многое другое.

  • Для того, чтобы скачать с сайта, необходимо зарегистрироваться, или войти под своим логином и паролем!

Ошибка в плагине WorldGuard

Neko-kun

Новорег
Сообщения
9
Реакции
0
Баллы
1
Поставил плагин WorldGuard на сервер, не работает, в консоли выдаёт ошибку
[20:31:53 ERROR]: Could not load plugins\worldguard.jar in folder plugins because plugin invalid
org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandsManager
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:130) ~[JavaPluginLoader.class:?]
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:323) ~[SimplePluginManager.class:?]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:245) [SimplePluginManager.class:?]
at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:392) [CraftServer.class:?]
at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:337) [MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:316) [nz.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:588) [MinecraftServer.class:?]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_281]
Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandsManager
at java.lang.Class.forName0(Native Method) ~[?:1.8.0_281]
at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_281]
at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:59) ~[PluginClassLoader.class:?]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:126) ~[JavaPluginLoader.class:?]
... 7 more
Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandsManager
at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_281]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:117) ~[PluginClassLoader.class:?]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[PluginClassLoader.class:?]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_281]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_281]
at java.lang.Class.forName0(Native Method) ~[?:1.8.0_281]
at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_281]
at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:59) ~[PluginClassLoader.class:?]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:126) ~[JavaPluginLoader.class:?]
... 7 more
Как мне уже рассказали в моей прошлой теме(https://forum.black-minecraft.com/threads/oshibka-v-plagine-essentialsx-1-12-2.145/) не хватает каких-то данных. На данный момент насколько я понимаю с Bukkit.

Использую ядро mohit.
Версия 1.12.2
Используются моды и плагины, на данный момент моды не установлены.
Список плагинов:
EssentialsX
EssentialsXAntiBuild
EssentialsXChat
EssentialsXProtect
EssentialsXSpawn
LuckPerms
Vault
WorldGuard

2021-05-21_20.48.30.png

Безымянный.png
Так же прикрепляю полный лог в виде файла. Сменять ядро не хочу, помогите решить.
 

Вложения

  • 2021-05-21-1.txt
    529.2 КБ · Просмотры: 1

As Second Life Studio

Партнёры
Студия по разработке
GOLD
Сообщения
24
Реакции
4
Баллы
6
Попробуй использовать WorldEdit как мод, а не как плагин, только возможно придётся отказаться от WorldGuard'a

Вот ссылка на скачивание мода для версии 1.12.2

Если не получится, попробуй использовать FAWE как плагин. Вот ссылка на него.
 

Neko-kun

Новорег
Сообщения
9
Реакции
0
Баллы
1
Попробуй использовать WorldEdit как мод, а не как плагин, только возможно придётся отказаться от WorldGuard'a

Вот ссылка на скачивание мода для версии 1.12.2

Если не получится, попробуй использовать FAWE как плагин. Вот ссылка на него.
Так у меня впринципе нету WorldEdit, у меня стоит только WorldGuard
 
Верх